[SOLVED] Flutter : AAPT: error: unexpected element <queries> found in <manifest>.

The Android Gradle Plugin needs to know about new manifest elements, particularly for the manifest merger process. The plugin has a tendency to get confused if it sees elements in the manifest merger that it does not recognize, tossing out build errors like the one in the question. In this case, Android 11 was introducedĀ <queries>Ā as a manifest element, and older versions of the Android Gradle Plugin do not know about that element. PROBLEM SOLUTION I had this issue in flutter

Read more